|MDOC.SAMPLES(7)||Miscellaneous Information Manual||MDOC.SAMPLES(7)|
tutorial sampler for writing BSD manuals with -mdoc
BSD manual pages with the
-mdoc macro package, a
domain-based formatting package for
Its predecessor, the
package, addressed page layout, leaving the manipulation of fonts and other
typesetting details to the individual author. In
-mdoc, page layout macros make up the
page structure domain which consists of macros
for titles, section headers, displays and lists. Essentially items which
affect the physical position of text on a formatted page. In addition to the
page structure domain, there are two more domains, the manual domain and the
general text domain. The general text domain is defined as macros which
perform tasks such as quoting or emphasizing pieces of text. The manual domain
is defined as macros that are a subset of the day to day informal language
used to describe commands, routines and related BSD
files. Macros in the manual domain handle command names, command-line
arguments and options, function names, function parameters, pathnames,
variables, cross references to other manual pages, and so on. These domain
items have value for both the author and the future user of the manual page.
It is hoped the consistency gained across the manual set will provide easier
translation to future documentation tools.
Throughout the UNIX manual pages, a manual entry is
simply referred to as a man page, regardless of actual length and without
To prevent a two character string from being interpreted as a macro name, precede the string with the escape sequence ‘Here the strings ‘One way of passing a string containing blank spaces is to use the hard or unpaddable space character ‘If the ‘The first items in the template are the macros (In the third case, discussion of commands and command syntax includes both examples above, but may add more detail. The arguments infile and outfile from the example above might be referred to as operands or file arguments. Some command-line argument lists are quite long:Here one might talk about the command make and qualify the argument makefile, as an argument to the flag, -f, or discuss the optional file operand target. In the verbal context, such detail can prevent confusion, however the -mdoc package does not have a macro for an argument to a flag. Instead the ‘The ‘The problem is that troff may assume it is supposed to actually perform the operation or evaluation suggested by the characters. To prevent the accidental evaluation of these characters, escape them with ‘It is an error to call ‘The ‘If ‘Produces:The ‘The ‘Produce: [[-k kilobytes] [-i interval] [-c count]] The macros ‘The ‘The ‘
Except for the irregular macros noted below, all of the quoting macros are parsed and callable. All handle punctuation properly, as long as it is presented one character at a time and separated by spaces. The quoting macros examine opening and closing punctuation to determine whether it comes before or after the enclosing string This makes some nesting possible.For a good example of nested enclosure macros, see the ‘Note: the ‘The macros beginning with ‘
The atexit() function returns the value 0 if successful; otherwise the value -1 is returned and the global variable errno is set to indicate the error. The -std option is valid only for manual page sections 2 and 3.ProducesAnother one:ProducesAnother example of ‘ProducesAll of the above examples have used the ‘Produces:Here is a hanged list with two items:The tagged list which follows uses an optional width specifier to control the width of the tag.The raw text:Acceptable width specifiers:If a width is not specified for the tag list type, the first time ‘
Note: The string named
‘The resulting output:The first line of information tells the name of the calling macro, here ‘The argument ‘
- TROFF IDIOSYNCRASIES
- Macro Usage.
- Passing Space Characters in an Argument.
- Trailing Blank Space Characters (a warning).
- Escaping Special Characters.
- THE ANATOMY OF A MAN PAGE
- A manual page template.
- TITLE MACROS.
- INTRODUCTION OF MANUAL AND GENERAL TEXT DOMAINS.
- What's in a name....
- General Syntax.
- MANUAL DOMAIN
- Author name.
- Configuration Declarations (section four only).
- Command Modifier.
- Defined Variables.
- Errno's (Section two only).
- Environment Variables.
- Function Argument.
- Function Declaration.
- Functions (library routines).
- Function Types.
- Interactive Commands.
- Cross References.
- GENERAL TEXT DOMAIN
- AT&T Macro.
- BSD Macro.
- FreeBSD Macro.
- UNIX Macro.
- Enclosure/Quoting Macros
- Angle Bracket Quote/Enclosure.
- Bracket Quotes/Enclosure.
- Double Quote macro/Enclosure.
- Parenthesis Quote/Enclosure.
- Single Quotes/Enclosure.
- Prefix Macro.
- No-Op or Normal Text Macro.
- No Space Macro.
- Section Cross References.
- References and Citations.
- Return Values (sections two and three only)
- Trade Names (Acronyms and Type Names).
- Extended Arguments.
- PAGE STRUCTURE DOMAIN
- Section Headers.
- Paragraphs and Line Spacing.
- Font Modes (Emphasis, Literal, and Symbolic).
- Lists and Columns.
- PREDEFINED STRINGS
- FORMATTING WITH GROFF, TROFF AND NROFF
.’ (dot character) at the beginning of a line followed by the two character name for the macro. Arguments may follow the macro separated by spaces. It is the dot character at the beginning of the line which causes troff(1) to interpret the next two characters as a macro name. To place a ‘
.’ (dot character) at the beginning of a line in some context other than a macro invocation, precede the ‘
.’ (dot) with the ‘
\&’ escape sequence. The ‘
\&’ translates literally to a zero width space, and is never displayed in the output. In general, troff(1) macros accept up to nine arguments, any extra arguments are ignored. Most macros in -mdoc accept nine arguments and, in limited cases, arguments may be continued or extended on the next line (See Extensions). A few macros handle quoted arguments (see Passing Space Characters in an Argument below). Most of the -mdoc general text domain and manual domain macros are special in that their argument lists are parsed for callable macro names. This means an argument on the argument list which matches a general text or manual domain macro name and is determined to be callable will be executed or called when it is processed. In this case, the argument, although the name of a macro, is not preceded by a ‘
.’ (dot). It is in this manner that many macros are nested; for example the option macro, ‘
.Op’, may call the flag and argument macros, ‘
Fl’ and ‘
Ar’, to specify an optional flag with an argument:
- [-s bytes]
- is produced by
.Op Fl s Ar bytes
- [Fl s Ar bytes]
- is produced by
.Op \&Fl s \&Ar bytes
Fl’ and ‘
Ar’ are not interpreted as macros. Macros whose argument lists are parsed for callable arguments are referred to as parsed and macros which may be called from an argument list are referred to as callable throughout this document and in the companion quick reference manual mdoc(7). This is a technical faux pas as almost all of the macros in -mdoc are parsed, but as it was cumbersome to constantly refer to macros as being callable and being able to call other macros, the term parsed has been used.
.Fn’ expects the first argument to be the name of a function and any remaining arguments to be function parameters. As ANSI C stipulates the declaration of function parameters in the parenthesized parameter list, each parameter is guaranteed to be at minimum a two word string. For example, int foo. There are two possible ways to pass an argument which contains an embedded space. Implementation note: Unfortunately, the most convenient way of passing spaces in between quotes by reassigning individual arguments before parsing was fairly expensive speed wise and space wise to implement in all the macros for AT&T troff. It is not expensive for groff but for the sake of portability, has been limited to the following macros which need it the most:
- Configuration declaration (section 4 SYNOPSIS)
- Begin list (for the width specifier).
- Emphasized text.
- Functions (sections two and four).
- List items.
- Literal text.
- Symbolic text.
- Book titles.
- Journal names.
- Optional notes for a reference.
- Report title (in a reference).
- Title of article in a book or journal.
\’, that is, a blank space preceded by the escape character ‘
\’. This method may be used with any macro but has the side effect of interfering with the adjustment of text over the length of a line. Troff sees the hard space as if it were any other printable character and cannot split the string into blank or newline separated pieces as one would expect. The method is useful for strings which are not expected to overlap a line boundary. For example:
- fetch(char *str)
- is created by ‘
.Fn fetch char\ *str’
- fetch(char *str)
- can also be created by ‘
.Fn fetch \*qchar *str\*q’
\’ or quotes were omitted, ‘
.Fn’ would see three arguments and the result would be:
For an example of what happens when the parameter list overlaps a newline boundary, see the BUGS section. Troff can be confused by blank space characters at the end of a line. It is a wise preventive measure to globally remove all blank spaces from <blank-space><end-of-line> character sequences. Should the need arise to force a blank character at the end of a line, it may be forced with an unpaddable space and the ‘
\&’ escape character. For example, ‘
\n’, are handled by replacing the ‘
\’ with ‘
\e’ (e.g., ‘
\en’) to preserve the backslash.
.\" The following requests are required for all man pages. .Dd Month day, year .Os OPERATING_SYSTEM [version/release] .Dt DOCUMENT_TITLE [section number] [volume] .Sh NAME .Nm name .Nd one line description of name .Sh SYNOPSIS .Sh DESCRIPTION .\" The following requests should be uncommented and .\" used where appropriate. This next request is .\" for sections 2 and 3 function return values only. .\" .Sh RETURN VALUE .\" This next request is for sections 1, 6, 7 & 8 only .\" .Sh ENVIRONMENT .\" .Sh FILES .\" .Sh EXAMPLES .\" This next request is for sections 1, 6, 7 & 8 only .\" (command return values (to shell) and .\" fprintf/stderr type diagnostics) .\" .Sh DIAGNOSTICS .\" The next request is for sections 2 and 3 error .\" and signal handling only. .\" .Sh ERRORS .\" .Sh SEE ALSO .\" .Sh CONFORMING TO .\" .Sh HISTORY .\" .Sh AUTHORS .\" .Sh BUGS
.Dt); the document date, the operating system the man page or subject source is developed or modified for, and the man page title (in uppercase) along with the section of the manual the page belongs in. These macros identify the page, and are discussed below in TITLE MACROS. The remaining items in the template are section headers (
.Sh); of which NAME, SYNOPSIS and DESCRIPTION are mandatory. The headers are discussed in PAGE STRUCTURE DOMAIN, after presentation of MANUAL DOMAIN. Several content macros are used to demonstrate page layout macros; reading about content macros before page layout macros is recommended.
.Dt DOCUMENT_TITLE section# [volume]
- The document title is the subject of the man page and must
be in CAPITALS due to troff limitations. The section number may be
1, ..., 8, and if it is specified, the volume title may be
omitted. A volume title may be arbitrary or one of the following:
UNIX Ancestral Manual Documents
UNIX System Manager's Manual
UNIX Reference Manual
UNIX Programmer's Manual
URMfor sections 1, 6, and 7;
SMMfor section 8;
PRMfor sections 2, 3, 4, and 5.
.Os operating_system release#
- The name of the operating system should be the common
acronym, for example, BSD or FreeBSD or ATT. The release should be the
standard release nomenclature for the system specified, for example, 4.3,
4.3+Tahoe, V.3, V.4. Unrecognized arguments are displayed as given in the
page footer. For instance, a typical footer might be:
.Os 4.3BSDor for a locally produced set
.Os FreeBSD 2.2The Berkeley default, ‘
.Os CS Department
.Os’ without an argument, has been defined as BSD in the site-specific file /usr/share/tmac/mdoc/doc-common. It really should default to LOCAL. Note, if the ‘
.Os’ macro is not present, the bottom left corner of the page will be ugly.
.Dd month day, year
- The date should be written formally:
January 25, 1989
.Va argument1 argument2 ... argument9The ‘
.Va’ is a macro command or request, and anything following it is an argument to be processed. In the second case, the description of a UNIX command using the content macros is a bit more involved; a typical SYNOPSIS command line might be displayed as:
filter [-flag] infile outfileHere, filter is the command name and the bracketed string -flag is a flag argument designated as optional by the option brackets. In -mdoc terms, infile and outfile are called arguments. The macros which formatted the above example:
.Nm filter .Op Fl flag .Ar infile outfile
- [-eiknqrstv] [-D variable] [-d flags] [-f makefile] [-I directory] [-j max_jobs] [variable=value] [target ...]
Ar’ argument macro is used for an operand or file argument like target as well as an argument to a flag like variable. The make command line was produced from:
.Nm make .Op Fl eiknqrstv .Op Fl D Ar variable .Op Fl d Ar flags .Op Fl f Ar makefile .Op Fl I Ar directory .Op Fl j Ar max_jobs .Op Ar variable=value .Bk -words .Op Ar target ... .Ek
.Bk’ and ‘
.Ek’ macros are explained in Keeps.
.Nm’, and ‘
.Pa’ differ only when called without arguments; ‘
.Fn’ and ‘
.Xr’ impose an order on their argument lists and the ‘
.Op’ and ‘
.Fn’ macros have nesting limitations. All content macros are capable of recognizing and properly handling punctuation, provided each punctuation character is separated by a leading space. If a request is given:
The result is:
.Li sptr, ptr),
The punctuation is not recognized and all is output in the literal font. If the punctuation is separated by a leading white space:
The result is:
.Li sptr , ptr ) ,
The punctuation is now recognized and is output in the default font distinguishing it from the strings in literal font. To remove the special meaning from a punctuation character escape it with ‘
\&’. Troff is limited as a macro language, and has difficulty when presented with a string containing a member of the mathematical, logical or quotation set:
\&’. Typical syntax is shown in the first content macro displayed below, ‘
Usage: .Ad address ... [.,:;()?!]
.Ad’ without arguments. ‘
.Ad’ is callable by other macros and is parsed.
.An’ macro is used to specify the name of the author of the item being documented, or the name of the author of the actual manual page. Any remaining arguments after the name information are assumed to be punctuation.
Usage: .An author_name [.,:;()?!]
.An’ macro is parsed and is callable. It is an error to call ‘
.An’ without any arguments.
.Ar’ argument macro may be used whenever a command-line argument is referenced.
Usage: .Ar argument ... [.,:;()?!]
.Ar’ is called without arguments, ‘
Ar’ is assumed. The ‘
.Ar’ macro is parsed and is callable.
.Cd’ macro is used to demonstrate a config(8) declaration for a device interface in a section four manual. This macro accepts quoted arguments (double quotes only).
- device le0 at scode?
- produced by: ‘
.Cd device le0 at scode?’.
.Fl’ (flag) command with the exception the ‘
.Cm’ macro does not assert a dash in front of every argument. Traditionally flags are marked by the preceding dash, some commands or subsets of commands do not use them. Command modifiers may also be specified in conjunction with interactive commands such as editor commands. See Flags.
Usage: .Dv defined_variable ... [.,:;()?!]
.Dv’ without arguments. ‘
.Dv’ is parsed and is callable.
.Er’ errno macro specifies the error return value for section two library routines. The second example below shows ‘
.Er’ used with the ‘
.Bq’ general text domain macro, as it would be used in a section two manual page.
Usage: .Er ERRNOTYPE ... [.,:;()?!]
.Er’ without arguments. The ‘
.Er’ macro is parsed and is callable.
.Ev’ macro specifies an environment variable.
Usage: .Ev argument ... [.,:;()?!]
.Ev’ without arguments. The ‘
.Ev’ macro is parsed and is callable.
.Fa’ macro is used to refer to function arguments (parameters) outside of the SYNOPSIS section of the manual or inside the SYNOPSIS section should a parameter list be too long for the ‘
.Fn’ macro and the enclosure macros ‘
.Fo’ and ‘
.Fc’ must be used. ‘
.Fa’ may also be used to refer to structure members.
Usage: .Fa function_argument ... [.,:;()?!]
.Fa’ without arguments. ‘
.Fa’ is parsed and is callable.
.Fd’ macro is used in the SYNOPSIS section with section two or three functions. The ‘
.Fd’ macro does not call other macros and is not callable by other macros.
In the SYNOPSIS section a ‘
Usage: .Fd include_file (or defined variable)
.Fd’ request causes a line break if a function has already been presented and a break has not occurred. This leaves a nice vertical space in between the previous function call and the declaration for the next function.
.Fl’ macro handles command-line flags. It prepends a dash, ‘
-’, to the flag. For interactive command flags, which are not prepended with a dash, the ‘
.Cm’ (command modifier) macro is identical, but without the dash.
Usage: .Fl argument ... [.,:;()?!]
.Fl’ macro without any arguments results in a dash representing stdin/stdout. Note that giving ‘
.Fl’ a single dash, will result in two dashes. The ‘
.Fl’ macro is parsed and is callable.
Usage: .Fn [type] function [[type] parameters ... [ .,:;()?! ]]
.Fn strlen ) ,
.Fn \*qint align\*q \*qconst * char *sptrs\*q,
- int align(const * char *sptrs),
.Fn’ without any arguments. The ‘
.Fn’ macro is parsed and is callable, note that any call to another macro signals the end of the ‘
.Fn’ call (it will close-parenthesis at that point). For functions that have more than eight parameters (and this is rare), the macros ‘
.Fo’ (function open) and ‘
.Fc’ (function close) may be used with ‘
.Fa’ (function argument) to get around the limitation. For example:
.Fo "int res_mkquery" .Fa "int op" .Fa "char *dname" .Fa "int class" .Fa "int type" .Fa "char *data" .Fa "int datalen" .Fa "struct rrec *newrr" .Fa "char *buf" .Fa "int buflen" .Fc
int res_mkquery(int op, char *dname, int class, int type, char *data, int datalen, struct rrec *newrr, char *buf, int buflen);The ‘
.Fo’ and ‘
.Fc’ macros are parsed and are callable. In the SYNOPSIS section, the function will always begin at the beginning of line. If there is more than one function presented in the SYNOPSIS section and a function type has not been given, a line break will occur, leaving a nice vertical space between the current function name and the one prior. At the moment, ‘
.Fn’ does not check its word boundaries against troff line lengths and may split across a newline ungracefully. This will be fixed in the near future. SYNOPSIS section. It may be used anywhere else in the man page without problems, but its main purpose is to present the function type in kernel normal form for the SYNOPSIS of sections two and three (it causes a line break allowing the function name to appear on the next line).
Usage: .Ft type ... [.,:;()?!]
.Ft struct stat
- struct stat
.Ft’ request is not callable by other macros.
.Ic’ macro designates an interactive or internal command.
Usage: .Ic argument ... [.,:;()?!]
.Ic’ without arguments. The ‘
.Ic’ macro is parsed and is callable.
.Nm’ macro is used for the document title or subject name. It has the peculiarity of remembering the first argument it was called with, which should always be the subject name of the page. When called without arguments, ‘
.Nm’ regurgitates this initial name for the sole purpose of making less work for the author. Note: a section two or three document function name is addressed with the ‘
.Nm’ in the NAME section, and with ‘
.Fn’ in the SYNOPSIS and remaining sections. For interactive commands, such as the ‘
while’ command keyword in csh(1), the ‘
.Ic’ macro should be used. While the ‘
.Ic’ is nearly identical to ‘
.Nm’, it can not recall the first argument it was invoked with.
Usage: .Nm argument ... [.,:;()?!]
.Nm’ macro is parsed and is callable.
.Op’ macro places option brackets around the any remaining arguments on the command line, and places any trailing punctuation outside the brackets. The macros ‘
.Oc’ and ‘
.Oo’ may be used across one or more lines.
Usage: .Op options ... [.,:;()?!]
.Oc’ and ‘
.Oo .Op Fl k Ar kilobytes .Op Fl i Ar interval .Op Fl c Ar count .Oc
.Oc’ and ‘
.Oo’ are parsed and are callable.
.Pa’ macro formats pathnames or filenames.
Usage: .Pa pathname [.,:;()?!]
.Pa’ macro is parsed and is callable.
Usage: .Va variable ... [.,:;()?!]
.Va’ without any arguments. The ‘
.Va’ macro is parsed and is callable.
.Xr’ macro expects the first argument to be a manual page name, and the second argument, if it exists, to be either a section page number or punctuation. Any remaining arguments are assumed to be punctuation.
Usage: .Xr man_page [1,...,8] [.,:;()?!]
.Xr’ macro is parsed and is callable. It is an error to call ‘
.Xr’ without any arguments.
Usage: .At [v6 | v7 | 32v | V.1 | V.4] ... [ .,:;()?! ]
.At’ macro is not parsed and not callable It accepts at most two arguments.
Usage: .Bx [Version/release] ... [.,:;()?!]
.Bx’ macro is parsed and is callable.
Usage: .Fx Version.release ... [ .,:;()?! ]
.Fx 2.2 .
- FreeBSD 2.2.
.Fx’ macro is not parsed and not callable It accepts at most two arguments.
Usage: .Ux ... [.,:;()?!]
.Ux’ macro is parsed and is callable.
q’ to give a hint of quoting, but there are a few irregularities. For each enclosure macro there is also a pair of open and close macros which end in small letters ‘
o’ and ‘
c’ respectively. These can be used across one or more lines of text and while they have nesting limitations, the one line quote macros can be used inside of them.
|.Aq||.Ac||.Ao||Angle Bracket Enclosure||<string>|
|.Ec||.Eo||Enclose String (in XX)||XXstringXX|
|.Ql||Quoted Literal||`st' or string|
|.Qc||.Qo||Straight Double Quote||string|
- These macros expect the first argument to be the opening and closing strings respectively.
- The quoted literal macro behaves differently for troff than nroff. If formatted with nroff, a quoted literal is always quoted. If formatted with troff, an item is quoted only if the width of the item is less than three constant width characters. This is to make short strings more visible where the font change to literal (constant width) is less noticeable.
- The prefix macro is not callable, but it is parsed:
.Pf ( Fa name2
- becomes (name2.
.Ns’ (no space) macro performs the analogous suffix function.
.Op’ option macro. It was created from the same underlying enclosure macros as those presented in the list above. The ‘
.Xo’ and ‘
.Xc’ extended argument list macros were also built from the same underlying routines and are a good example of -mdoc macro usage at its worst.
.No’ is a hack for words in a macro command line which should not be formatted and follows the conventional syntax for content macros.
Space MacroThe ‘
.Ns’ macro eliminates unwanted spaces in between macro requests. It is useful for old style argument lists where there is no space between the flag and argument:
.Op Fl I Ns Ar directory
- produces [-Idirectory]
.Ns’ macro always invokes the ‘
.No’ macro after eliminating the space unless another macro name follows it. The macro ‘
.Ns’ is parsed and is callable.
.Sx’ macro designates a reference to a section header within the same document. It is parsed and is callable.
- Reference Start. Causes a line break and begins collection of reference information until the reference end macro is read.
- Reference End. The reference is printed.
- Reference author name, one name per invocation.
- Book title.
- Journal name.
- Issue number.
- Optional information.
- Page number.
- Report name.
- Title of article.
%’ are not callable, and are parsed only for the trade name macro which returns to its caller. (And not very predictably at the moment either.) The purpose is to allow trade names to be pretty printed in troff/ditroff output.
.Rv’ macro generates text for use in the RETURN VALUE section.
Usage: .Rv [-std function]
.Rv -std atexit’ will generate the following text:
The atexit() function returns the value 0 if successful; otherwise the value -1 is returned and the global variable errno is set to indicate the error. The -std option is valid only for manual page sections 2 and 3.
Usage: .Tn symbol ... [.,:;()?!]
.Tn’ macro is parsed and is callable by other macros.
.Xo’ and ‘
.Xc’ macros allow one to extend an argument list on a macro boundary. Argument lists cannot be extended within a macro which expects all of its arguments on one line such as ‘
.Op’. Here is an example of ‘
.Xo’ using the space mode macro to turn spacing off:
.Sm off .It Xo Sy I Ar operation .No \en Ar count No \en .Xc .Sm on
.Sm off .It Cm S No / Ar old_pattern Xo .No / Ar new_pattern .No / Op Cm g .Xc .Sm on
.Xo’ and using enclosure macros: Test the value of a variable.
.It Xo .Ic .ifndef .Oo \&! Oc Ns Ar variable .Op Ar operator variable ... .Xc
- .ifndef [!]variable [operator variable ...]
.Xo’ macro on the argument list of the ‘
.It’ (list-item) macro. The extend macros are not used very often, and when they are it is usually to extend the list-item argument list. Unfortunately, this is also where the extend macros are the most finicky. In the first two examples, spacing was turned off; in the third, spacing was desired in part of the output but not all of it. To make these macros work in this situation make sure the ‘
.Xo’ and ‘
.Xc’ macros are placed as shown in the third example. If the ‘
.Xo’ macro is not alone on the ‘
.It’ argument list, spacing will be unpredictable. The ‘
.Ns’ (no space macro) must not occur as the first or last macro on a line in this situation. Out of 900 manual pages (about 1500 actual pages) currently released with BSD only fifteen use the ‘
.Sh’ section header macros list below are required in every man page. The remaining section headers are recommended at the discretion of the author writing the manual page. The ‘
.Sh’ macro can take up to nine arguments. It is parsed and but is not callable.
- .Sh NAME
- The ‘
.Sh NAME’ macro is mandatory. If not specified, the headers, footers and page layout defaults will not be set and things will be rather unpleasant. The NAME section consists of at least three items. The first is the ‘
.Nm’ name macro naming the subject of the man page. The second is the Name Description macro, ‘
.Nd’, which separates the subject name from the third item, which is the description. The description should be the most terse and lucid possible, as the space available is small.
- .Sh SYNOPSIS
- The SYNOPSIS
section describes the typical usage of the subject of a man page. The
macros required are either ‘
.Fn’, (and possibly ‘
.Ft’ macros). The function name macro ‘
.Fn’ is required for manual page sections 2 and 3, the command and general name macro ‘
.Nm’ is required for sections 1, 5, 6, 7, 8. Section 4 manuals require a ‘
.Fd’ or a ‘
.Cd’ configuration device usage macro. Several other macros may be necessary to produce the synopsis line as shown below:
cat [-benstuv] [-] file ...The following macros were used:
.Op Fl benstuv
Note: The macros ‘
.Fl’, and ‘
.Ar’ recognize the pipe bar character ‘
|’, so a command line such as:
will not go orbital. Troff normally interprets a | as a special operator. See PREDEFINED STRINGS for a usable | character in other situations.
.Op Fl a | Fl b
- .Sh DESCRIPTION
- In most cases the first text in the
DESCRIPTION section is a
brief paragraph on the command, function or file, followed by a lexical
list of options and respective explanations. To create such a list, the
.Bl’ begin-list, ‘
.It’ list-item and ‘
.El’ end-list macros are used (see Lists and Columns below).
.Sh’ section headers are part of the preferred manual page layout and must be used appropriately to maintain consistency. They are listed in the order in which they would be used.
- .Sh ENVIRONMENT
- The ENVIRONMENT section should reveal any related environment variables and clues to their behavior and/or usage.
- .Sh EXAMPLES
- There are several ways to create examples. See the EXAMPLES section below for details.
- .Sh FILES
- Files which are used or created by the man page subject
should be listed via the ‘
.Pa’ macro in the FILES section.
- .Sh SEE ALSO
- References to other material on the man page topic and
cross references to other relevant man pages should be placed in the
SEE ALSO section. Cross
references are specified using the
.Xr’ macro. Cross references in the SEE ALSO section should be sorted by section number, and then placed in alphabetical order and comma separated. For example: ls(1), ps(1), group(5), passwd(5). At this time refer(1) style references are not accommodated.
- .Sh CONFORMING TO
- If the command, library function or file adheres to a specific implementation such as IEEE Std 1003.2 (“POSIX.2”) or ANSI X3.159-1989 (“ANSI C89”) this should be noted here. If the command does not adhere to any standard, its history should be noted in the HISTORY section.
- .Sh HISTORY
- Any command which does not adhere to any specific standards should be outlined historically in this section.
- .Sh AUTHORS
- Credits, if need be, should be placed here.
- .Sh DIAGNOSTICS
- Diagnostics from a command should be placed in this section.
- .Sh ERRORS
- Specific error handling, especially from library functions
(man page sections 2 and 3) should go here. The
.Er’ macro is used to specify an errno.
- .Sh BUGS
- Blatant problems with the topic go here...
.Sh’ sections may be added, for example, this section was set with:
.Sh PAGE STRUCTURE DOMAIN
- The ‘
.Pp’ paragraph command may be used to specify a line space where necessary. The macro is not necessary after a ‘
.Sh’ or ‘
.Ss’ macro or before a ‘
.Bl’ macro. (The ‘
.Bl’ macro asserts a vertical distance unless the -compact flag is given).
.Bk’ (begin-keep) and ‘
.Ek’ (end-keep). The only option that ‘
.Bk’ accepts is -words and is useful for preventing line breaks in the middle of options. In the example for the make command-line arguments (see What's in a name), the keep prevented nroff from placing up the flag and the argument on separate lines. (Actually, the option macro used to prevent this from occurring, but was dropped when the decision (religious) was made to force right justified margins in troff as options in general look atrocious when spread across a sparse line. More work needs to be done with the keep macros, a -line option needs to be added.)
.D1’, a quickie one line literal display ‘
.Dl’, and a block literal, block filled and block ragged which use the ‘
.Bd’ begin-display and ‘
.Ed’ end-display macros.
- (D-one) Display one line of indented text. This macro is
parsed, but it is not callable.
The above was produced by:
- (D-ell) Display one line of indented
literal text. The
.Dl’ example macro has been used throughout this file. It allows the indent (display) of one line of text. Its default font is set to constant width (literal) however it is parsed and will recognized other macros. It is not callable however.The above was produced by
% ls -ldg /usr/local/bin
.Dl % ls -ldg /usr/local/bin.
- Begin-display. The
.Bd’ display must be ended with the ‘
.Ed’ macro. Displays may be nested within displays and lists. ‘
.Bd’ has the following syntax:The display-type must be one of the following four types and may have an offset specifier for indentation: ‘
.Bd display-type [-offset offset_value] [-compact]
- Display a block of text as typed, right (and left) margin edges are left ragged.
- Display a filled (formatted) block. The block of text is formatted (the edges are filled - not left unjustified).
- Display a literal block, useful for source code or simple tabbed or spaced text.
- -file file_name
- The filename following the -file flag is read and displayed. Literal mode is asserted and tabs are set at 8 constant width character intervals, however any troff/-mdoc commands in file will be processed.
- -offset string
- If -offset is specified with
one of the following strings, the string is interpreted to indicate the
level of indentation for the forthcoming block of text:
- Align block on the current left margin, this is the
default mode of ‘
- Supposedly center the block. At this time unfortunately, the block merely gets left aligned about an imaginary center margin.
- Indents by one default indent value or tab. The default
indent value is also used for the
.D1’ display so one is guaranteed the two types of displays will line up. This indent is normally set to 6n or about two thirds of an inch (six constant width characters).
- Indents two times the default indent value.
- This left aligns the block about two inches from the right side of the page. This macro needs work and perhaps may never do the right thing by troff.
- Text may be stressed or emphasized with the
.Em’ macro. The usual font for emphasis is italic.
Usage: .Em argument ... [.,:;()?!]
.Em’ macro is parsed and is callable. It is an error to call ‘
.Em’ without arguments.
- The ‘
.Li’ literal macro may be used for special characters, variable constants, anything which should be displayed as it would be typed.
Usage: .Li argument ... [.,:;()?!]
.Li’ macro is parsed and is callable.
- The symbolic emphasis macro is generally a boldface macro
in either the symbolic sense or the traditional English usage.
Usage: .Sy symbol ... [.,:;()?!]
.Sy Important Notice
- Important Notice
.Sy’ macro is parsed and is callable. Arguments to ‘
.Sy’ may be quoted.
- Begin font mode. The
.Bf’ font mode must be ended with the ‘
.Ef’ macro. Font modes may be nested within other font modes. ‘
.Bf’ has the following syntax:The font-mode must be one of the following three types: ‘
- End font mode.
.Bl’ begin-list macro. Items within the list are specified with the ‘
.It’ item macro and each list must end with the ‘
.El’ macro. Lists may be nested within themselves and within displays. Columns may be used inside of lists, but lists are unproven inside of columns. In addition, several list attributes may be specified such as the width of a tag, the list offset, and compactness (blank lines between items allowed or disallowed). Most of this document has been formatted with a tag style list (-tag). For a change of pace, the list-type used to present the list-types is an over-hanging list (-ohang). This type of list is quite popular with TeX users, but might look a bit funny after having read many pages of tagged lists. The following list types are accepted by ‘
- These three are the simplest types of lists. Once the
.Bl’ macro has been given, items in the list are merely indicated by a line consisting solely of the ‘
.It’ macro. For example, the source text for a simple enumerated list would look like:
.Bl -enum -compact .It Item one goes here. .It And item two here. .It Lastly item three goes here. .El
- Item one goes here.
- And item two here.
- Lastly item three goes here.
.Bl -bullet -compact .It Bullet one goes here. .It Bullet two here. .El
- Bullet one goes here.
- Bullet two here.
- These list-types collect arguments specified with the
.It’ macro and create a label which may be inset into the forthcoming text, hanged from the forthcoming text, overhanged from above and not indented or tagged. This list was constructed with the ‘
Fl ohang’ list-type. The ‘
.It’ macro is parsed only for the inset, hang and tag list-types and is not callable. Here is an example of inset labels:
- The tagged list (also called a tagged paragraph) is the most common type of list used in the Berkeley manuals.
- Diag lists create section four diagnostic lists and are similar to inset lists except callable macros are ignored.
- Hanged labels are a matter of taste.
- Overhanging labels are nice when space is constrained.
- Inset labels are useful for controlling blocks of paragraphs and are valuable for converting -mdoc manuals to other formats.
.Bl -inset -offset indent .It Em Tag The tagged list (also called a tagged paragraph) is the most common type of list used in the Berkeley manuals. .It Em Diag Diag lists create section four diagnostic lists and are similar to inset lists except callable macros are ignored. .It Em Hang Hanged labels are a matter of taste. .It Em Ohang Overhanging labels are nice when space is constrained. .It Em Inset Inset labels are useful for controlling blocks of paragraphs and are valuable for converting .Nm -mdoc manuals to other formats. .El
- labels appear similar to tagged lists when the label is smaller than the label width.
- Longer hanged list labels
- blend in to the paragraph unlike tagged paragraph labels.
.Bl -hang -offset indent .It Em Hanged labels appear similar to tagged lists when the label is smaller than the label width. .It Em Longer hanged list labels blend in to the paragraph unlike tagged paragraph labels. .El
- sleep time of the process (seconds blocked)
- number of disk I/O's resulting from references by the process to pages not loaded in core.
- numerical user-id of process owner
- numerical ID of parent of process process priority (nonpositive when in noninterruptible wait)
.Bl -tag -width "PAGEIN" -compact -offset indent .It SL sleep time of the process (seconds blocked) .It PAGEIN number of disk .Tn I/O Ns 's resulting from references by the process to pages not loaded in core. .It UID numerical user ID of process owner .It PPID numerical ID of parent of process process priority (nonpositive when in noninterruptible wait) .El
- -width Fl
- sets the width to the default width for a flag. All
callable macros have a default width value. The
.Fl’, value is presently set to ten constant width characters or about five sixth of an inch.
- -width 24n
- sets the width to 24 constant width characters or about two
inches. The ‘
n’ is absolutely necessary for the scaling to work correctly.
- -width ENAMETOOLONG
- sets width to the constant width length of the string given.
- -width \*qint mkfifo\*q
- again, the width is set to the constant width of the string given.
.It’ is invoked, an attempt is made to determine an appropriate width. If the first argument to ‘
.It’ is a callable macro, the default width for that macro will be used as if the macro name had been supplied as the width. However, if another item in the list is given with a different callable macro name, a new and nested list is assumed.
\*(xx’ where xx is the name of the defined string or as ‘
\*x’ where x is the name of the string. The interpreting sequence may be used any where in the text.
q’ should be written as ‘
\*q’ since it is only one char. troff with a one or two character name. All registers internal to -mdoc for troff and ditroff are two characters and of the form <upper_case><lower_case> such as ‘
Ar’, <lower_case><upper_case> as ‘
aR’ or <upper or lower letter><digit> as ‘
C1’. And adding to the muddle, troff has its own internal registers all of which are either two lowercase characters or a dot plus a letter or metacharacter character. In one of the introduction examples, it was shown how to prevent the interpretation of a macro name with the escape sequence ‘
\&’. This is sufficient for the internal register names also. If a nonescaped register name is given in the argument list of a request, unpredictable behavior will occur. In general, any time huge portions of text do not appear where expected in the output, or small strings such as list tags disappear, chances are there is a misunderstanding about an argument type in the argument list. Your mother never intended for you to remember this evil stuff - so here is a way to find out whether or not your arguments are valid: The ‘
.Db’ (debug) macro displays the interpretation of the argument list for most macros. Macros such as the ‘
.Pp’ (paragraph) macro do not contain debugging information. All of the callable macros do, and it is strongly advised whenever in doubt, turn on the ‘
An example of a portion of text with the debug macro placed above and below an artificially created problem (a flag argument ‘
Usage: .Db [on | off]
aC’ which should be ‘
\&aC’ in order to work):
.Db on .Op Fl aC Ar file ) .Db off
DEBUGGING ON DEBUG(argv) MACRO: `.Op' Line #: 2 Argc: 1 Argv: `Fl' Length: 2 Space: `' Class: Executable Argc: 2 Argv: `aC' Length: 2 Space: `' Class: Executable Argc: 3 Argv: `Ar' Length: 2 Space: `' Class: Executable Argc: 4 Argv: `file' Length: 4 Space: ` ' Class: String Argc: 5 Argv: `)' Length: 1 Space: ` ' Class: Closing Punctuation or suffix MACRO REQUEST: .Op Fl aC Ar file ) DEBUGGING OFF
.Op’, and the line number it appears on. If one or more files are involved (especially if text from another file is included), the line number may be bogus. If there is only one file, it should be accurate. The second line gives the argument count, the argument (‘
Fl’) and its length. If the length of an argument is two characters, the argument is tested to see if it is executable (unfortunately, any register which contains a nonzero value appears executable). The third line gives the space allotted for a class, and the class type. The problem here is the argument aC should not be executable. The four types of classes are string, executable, closing punctuation and opening punctuation. The last line shows the entire argument list as it was read. In this next example, the offending ‘
aC’ is escaped:
.Db on .Em An escaped \&aC .Db off
DEBUGGING ON DEBUG(fargv) MACRO: `.Em' Line #: 2 Argc: 1 Argv: `An' Length: 2 Space: ` ' Class: String Argc: 2 Argv: `escaped' Length: 7 Space: ` ' Class: String Argc: 3 Argv: `aC' Length: 2 Space: ` ' Class: String MACRO REQUEST: .Em An escaped &aC DEBUGGING OFF
\&aC’ shows up with the same length of 2 as the ‘
\&’ sequence produces a zero width, but a register named ‘
\&aC’ was not found and the type classified as string. Other diagnostics consist of usage statements and are self explanatory. groff. The package inhibits page breaks, and the headers and footers which normally occur at those breaks with nroff, to make the manual more efficient for viewing on-line. At the moment, groff with -Tascii does eject the imaginary remainder of the page at end of file. The inhibiting of the page breaks makes nroff'd files unsuitable for hardcopy. There is a register named ‘
cR’ which can be set to zero in the site dependent style file /usr/src/share/tmac/doc-nroff to restore the old style behavior.
- manual macro package
- template for writing a man page
- several example man pages
.Nm’ font should be changed in NAME section. ‘
.Fn’ needs to have a check to prevent splitting up if the line length is too short. Occasionally it separates the last parenthesis, and sometimes looks ridiculous if a line is in fill mode. The method used to prevent header and footer page breaks (other than the initial header and footer) when using nroff occasionally places an unsightly partially filled line (blank) at the would be bottom of the page. The list and display macros to not do any keeps and certainly should be able to. man(1), troff(1), groff_mdoc(7), mdoc(7)
|December 30, 1993||Linux 4.16.6-1-ARCH|