Arch manual pages

PWCONV(8) Comandi per la gestione del si PWCONV(8)

pwconv, pwunconv, grpconv, grpunconv - convertono a e da password e gruppi shadow.

pwconv [opzioni]

pwunconv [opzioni]

grpconv [opzioni]

grpunconv [opzioni]

pwconv crea shadow da passwd e da un eventuale preesistente shadow.

pwunconv crea passwd da passwd e shadow e poi cancella shadow.

grpconv crea gshadow da group e da un eventuale preesistente gshadow.

grpunconv crea group da group e gshadow e quindi rimuove gshadow.

Questi quattro programmi agiscono tutti sui file normali e oscurati (shadow) delle password e dei gruppi: /etc/passwd, /etc/group, /etc/shadow e /etc/gshadow.

Ciascun programma, prima della conversione, acquisisce i lock necessari. pwconv e grpconv sono simili. Per prima cosa vengono rimosse le voci nel file shadow che non esistono nel file principale. Quindi vengono aggiornate le voci oscurate che non hanno «x» come password nel file principale. Vengono aggiunte le eventuali voci oscurate mancanti. Infine, le password nel file principale vengono sostituite con «x». Questi programmi possono essere usati per le conversioni iniziali così come per aggiornare il file oscurato se il file principale viene modificato a mano.

pwconv userà i valori PASS_MIN_DAYS, PASS_MAX_DAYS e PASS_WARN_AGE da /etc/login.defs al momento dell'aggiunta di nuove voci a /etc/shadow.

Analogamente, pwunconv e grpunconv sono simili. Le password nel file principale vengono aggiornate dal file shadow. Voci che esistono nel file principale ma non nel file shadow vengono lasciate stare. Infine, viene rimosso il file shadow. Alcune informazioni sull'invecchiamento delle password vengono perse da pwunconv. Convertirà solo quello che potrà.

Le opzioni che si possono applicare ai comandi pwconv, pwunconv, grpconv e grpunconv sono:

-h, --help

Mostra un messaggio di aiuto ed esce.

-R, --root CHROOT_DIR

Effettua le modifiche nella directory CHROOT_DIR e usa i file di configurazione dalla directory CHROOT_DIR.

Errori nel file delle password o dei gruppi (come elementi non validi o duplicati) possono causare dei cicli infiniti in questi programmi, oppure degli errori non prevedibili. Eseguire pwck e grpck per correggere ogni eventuale errore prima di convertire da o verso password o gruppi shadow.

Le seguenti variabili di configurazione in /etc/login.defs influenzano il comportamento di grpconv e grpunconv:

MAX_MEMBERS_PER_GROUP (numero)

Numero massimo di membri per gruppo. Quando viene raggiunto il massimo, viene creata una nuova riga per il gruppo nel file /etc/group (con lo stesso nome, stessa password e stesso GID).

Il valore predefinito è 0, che non pone nessun limite al numero di membri per gruppo.

Questa opzione (dividi gruppo) permette di limitare la lunghezza delle righe nel file «group». Questo è utile per essere certi che le righe per gruppi NIS non eccedano i 1024 caratteri.

Se si deve impostare questo limite, si può usare 25.

Nota: la divisione dei gruppi potrebbe non essere supportata da ogni strumento (anche all'interno del pacchetto Shadow). Non si dovrebbe utilizzare questa variabile a meno di esserci forzati.

Le seguenti variabili di configurazione in /etc/login.defs influenzano il comportamento di pwconv:

PASS_MAX_DAYS (numerico)

Il numero massimo di giorni che una password può essere utilizzata. Se la password è più vecchia verrà imposto il suo cambiamento. Se non specificato viene assunto -1 (che disabilita questo controllo).

PASS_MIN_DAYS (numerico)

Il numero minimo di giorni tra due cambiamenti di password. Ogni tentativo di cambiare la password prima di questo periodo verrà rifiutato. Se non specificato viene assunto -1 (che disabilita questo controllo).

PASS_WARN_AGE (numerico)

Il numero di giorni per i quali un utente va avvisato che la sua password sta per scadere. Se zero l'utente viene avvisato solo alla scadenza. Un valore negativo indica che non si deve avvisare mai. Se non specificato allora non c'è nessun avviso.

/etc/login.defs
Configurazione del pacchetto password shadow

grpck(8), login.defs(5), pwck(8).
13/11/2019 shadow-utils 4.7