Arch manual pages

pwconv(8) Команды управления системой pwconv(8)

pwconv, pwunconv, grpconv, grpunconv - преобразует пароли пользователей и групп в/из защищённую форму

pwconv [параметры]

pwunconv [параметры]

grpconv [параметры]

grpunconv [параметры]

Команда pwconv создаёт файл shadow из файла passwd и необязательно существующего файла shadow.

Команда pwunconv создаёт файл passwd из файлов passwd и shadow, а затем удаляет файл shadow.

Команда grpconv создаёт файл gshadow из файла group и необязательно существующего файла gshadow.

Команда grpunconv создаёт файл group из файлов group и gshadow, а затем удаляет файл gshadow.

Эти четыре программы работают с файлами обычных или теневых паролей пользователей и групп: /etc/passwd, /etc/group, /etc/shadow и /etc/gshadow.

Каждая программа выполняет необходимые блокировки перед преобразованиями. Команды pwconv и grpconv выполняют схожий порядок действий. Сначала удаляются записи из теневого файла которых нет в главном файле. Затем обновляются записи в теневом файле которые не содержат «x» вместо пароля в главном файле. Далее добавляются отсутствующие теневые записи. Наконец, пароли в главном файле заменяются символом «x». Данные программы можно использовать как для первоначального преобразования, так и для обновления теневого файла, если главный файл редактировался вручную.

Команда pwconv использует значения переменных PASS_MIN_DAYS, PASS_MAX_DAYS и PASS_WARN_AGE из файла /etc/login.defs при добавлении новых записей в файл /etc/shadow.

Программы pwunconv и grpunconv также выполняют схожий порядок действий. Пароли в главном файле обновляются из теневого файла. Записи, которые существуют в главном файле, но не существуют в теневом файле оставляются как есть. По окончании, теневой файл удаляется. Информация об устаревании пароля не учитывается программой pwunconv. Конвертируется только возможное.

Параметры, применимые к pwconv, pwunconv, grpconv и grpunconv:

-h, --help

Показать краткую справку и закончить работу.

-R, --root КАТ_CHROOT

Выполнить изменения в каталоге КАТ_CHROOT и использовать файлы настройки из каталога КАТ_CHROOT.

Ошибки в файлах паролей или групп (типа неверных или дублирующихся записей) могут зациклить программу или произойдут какие-то другие странные вещи. Перед конвертацией запустите pwck и grpck, чтобы исправить возможные ошибки.

Следующая переменная настройки в /etc/login.defs изменяет поведение grpconv и grpunconv:

MAX_MEMBERS_PER_GROUP (число)

Максимальное количество членов в записи о группе. При достижения максимума заводится новая запись группы (строка) в /etc/group (с тем же именем, паролем и тем же GID).

Значение по умолчанию равно 0, означающее, что ограничения на количество членов в группе нет.

Данная возможность (разделение группы) позволяет ограничить длину строк в файле групп. Это полезно для ограничения длины строк групп NIS в 1024 символа.

Если вам нужно такое ограничение, укажите значение 25.

Замечание: разделение групп поддерживается не всеми инструментами (даже в наборе инструментов Shadow). Вы не должны использовать эту переменную, если вам действительно это ненужно.

Следующая переменная настройки в /etc/login.defs изменяет поведение pwconv:

PASS_MAX_DAYS (число)

Максимальное число дней использования пароля. Если пароль старее этого числа, то будет запущена процедура смены пароля. Если значение не задано, то предполагается значение -1 (то есть возможность ограничения не используется).

PASS_MIN_DAYS (число)

Максимальное число дней между изменениями пароля. Любая смена пароля ранее заданного срока выполнена не будет. Если значение не задано, то предполагается значение -1 (то есть возможность ограничения не используется).

PASS_WARN_AGE (число)

Число дней за которое начнёт выдаваться предупреждение об устаревании пароля. Нулевое значение означает, что предупреждение выдаётся в день устаревания, при отрицательном значении предупреждение выдаваться не будет. Если значение не задано, выдача предупреждения отключается.

/etc/login.defs
содержит конфигурацию подсистемы теневых паролей

grpck(8), login.defs(5), pwck(8).
07/31/2019 shadow-utils 4.7